Online and Mobile Banking Browser and Operating System Requirements

Salem Five is committed to providing its customers with the highest level of security available. Below are what is recommended for and what our systems support.


 

Last Updated Date: February 7, 2024

Minimum Requirements for using Online Banking

Windows10 Logo Windows 10



  • Edge
  • Chrome
  • Firefox

macOS Apple Logo macOSx10.14+ (Mojave, Catalina)



  • Chrome
  • Safari

Minimum Requirements for using Mobile Banking

Android Logo Android 10.0



Channel Support:

  • Android Application
  • SMS

macIOS Apple Logo mac iOS - 15.0, iPadOS 15



Channel Support:

  • SMS
 

Hardware/Browser Support:

  • Only devices running an unmodified version of the manufacturer-supplied operating system are supported
  • The latest stable version of Chrome and Safari browsers are supported
  • Beta versions of browsers are not supported
  • Developer option settings are not supported

Supported Networks:

AT&T®    |    Verizon®    |    T-Mobile® /Sprint  
 |    US Cellular® 
 

Certified Devices