System Requirements


Salem Five is committed to providing its customers with the highest level of security available. Any device or browser that does not support TLS 1.2 will not be able to connect.  It is likely that that other devices and applications may still fully function, but are not certified and/or supported.

Certified Devices effective April 2019

Phone Channel

Operating SystemMinimum OS
Version Support
Browser SupportChannel Support
Android Android version 5.0 (Lollipop) Default installed browser
(Android, Chrome)
Touch Browser
Android Application
SMS
iPhone iOS version 11 Default installed browser
(Safari)
Touch Browser
Android Application
SMS


Desktop

Desktop Web ApplicationDesktop OS
Supported Browser(s)Allowed Browsers
Internet Self Service (accessed through online banking) Windows 7 Internet Explorer 11
Chrome - Latest stable
Firefox - Latest stable
Internet Explorer 9
  Windows 10 Internet Explorer 11 (default)
Chrome - Latest stable
Firefox - Latest stable
Microsoft Edge
  Mac OSX - Latest stable Safari - Latest stable  


Tablet Channel

Operating SystemMinimum OS
Version Support
Browser SupportApplication Support
Android Android version 5.0
(Lollipop)
Default installed browser
(Android, Chrome)
Touch Browser
Android Tablet Application
iOS  iOS version 11 Default installed browser
(Safari)
Touch Browser
iPad Application

 

Recommended Browsers for Salemfive.com

When visiting our website, we recommend using the latest browser versions of Chrome, Firefox and Safari for the best browsing experience.  Internet Explorer Version 11 and above is recommended.  Older browsers may be used, however, they are not supported and some features may not function properly.

Browsers are free to download and use. To download a browser, select one of the following: